Friday, November 17, 2017
Breaking News
Home » Jelambar » Load balancing 4 buah modem firstmedia dengan menggunakan mikrotik RB750

Load balancing 4 buah modem firstmedia dengan menggunakan mikrotik RB750

Terlalu lelah membuat saya tertidur agak cepat pada malam hari ini dan yang berimbas terbangun pada saat yang belum waktunya 🙁 teringat pula masih ada mikrotik rb 750 yang masih belum tersentuh sama sekali akan konfigurasinya, yang rencananya rb 750 ini akan digunakan untuk meload balancing 4 buah modem dari firstmedia / fastnet berikut gambaran bagaimana router ini akan di fungsikan nantinya..

4 wan loadbalancing

saya menggunakan router wired dalam hal ini untuk memberi ip statik pada tiap2 modem, yang masing2 akses dari 3 buah router ini mengarah pada ether 1 – 4 sementara ether 5 akan digunakan sebagai akses untuk mengarah ke LAN.

saya merubah nama masing2 interface terlebih dahulu untuk memudahkan dalam mengingat interface mana yang akan kita konfigurasi. seperti pada gambar dibawah

interface

setting ip address untuk masing2 interface

/ip address
add address=1.1.1.2/29 interface=WAN1
add address=2.2.2.2/29 interface=WAN2
add address=3.3.3.2/29 interface=WAN3
add address=4.4.4.2/29 interface=WAN4
add address=10.10.10.1/30 interface=Lokal

saya menggunakan subnet /29 pada WAN dikarenakan saya hanya membutuhkan sedikit blok ip yang aktif pada interface WAN. dan saya menggunakan subnet /30 karena saya mempunyai mikrotik lain yang akan difungsikan sebagai bandwidth management. jadi RB 750 ini hanya murni sebagai load balancing.

mangle

/ip firewall mangle
add chain=input in-interface=WAN1 action=mark-connection new-connection-mark=WAN1_out
add chain=input in-interface=WAN2 action=mark-connection new-connection-mark=WAN2_out
add chain=input in-interface=WAN3 action=mark-connection new-connection-mark=WAN3_out
add chain=input in-interface=WAN4 action=mark-connection new-connection-mark=WAN4_out


add chain=prerouting dst-address-type=!local in-interface=Lokal per-connection-classifier=both-addresses-and-ports:4/0 action=mark-connection new-connection-mark=WAN1_out passthrough=yes
add chain=prerouting dst-address-type=!local in-interface=Lokal per-connection-classifier=both-addresses-and-ports:4/1 action=mark-connection new-connection-mark=WAN2_out passthrough=yes
add chain=prerouting dst-address-type=!local in-interface=Lokal per-connection-classifier=both-addresses-and-ports:4/2 action=mark-connection new-connection-mark=WAN3_out passthrough=yes
add chain=prerouting dst-address-type=!local in-interface=Lokal per-connection-classifier=both-addresses-and-ports:4/3 action=mark-connection new-connection-mark=WAN4_out passthrough=yes


add chain=output connection-mark=WAN1_out action=mark-routing new-routing-mark=to_WAN1
add chain=output connection-mark=WAN2_out action=mark-routing new-routing-mark=to_WAN2
add chain=output connection-mark=WAN3_out action=mark-routing new-routing-mark=to_WAN3
add chain=output connection-mark=WAN4_out action=mark-routing new-routing-mark=to_WAN4


add chain=prerouting connection-mark=WAN1_out in-interface=Lokal action=mark-routing new-routing-mark=to_WAN1
add chain=prerouting connection-mark=WAN2_out in-interface=Lokal action=mark-routing new-routing-mark=to_WAN2
add chain=prerouting connection-mark=WAN3_out in-interface=Lokal action=mark-routing new-routing-mark=to_WAN3
add chain=prerouting connection-mark=WAN4_out in-interface=Lokal action=mark-routing new-routing-mark=to_WAN4


add chain=prerouting dst-address=1.1.1.0/29 action=accept in-interface=Lokal
add chain=prerouting dst-address=2.2.2.0/29 action=accept in-interface=Lokal
add chain=prerouting dst-address=3.3.3.0/29 action=accept in-interface=Lokal
add chain=prerouting dst-address=4.4.4.0/29 action=accept in-interface=Lokal

DNS


/ip dns set allow-remote-requests=yes servers=8.8.4.4,8.8.8.8

Routing
/ip route
add dst-address=0.0.0.0/0 gateway=1.1.1.1 routing-mark=to_WAN1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=2.2.2.1 routing-mark=to_WAN2 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=3.3.3.1 routing-mark=to_WAN3 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=4.4.4.1 routing-mark=to_WAN4 check-gateway=ping


add dst-address=0.0.0.0/0 gateway=1.1.1.1 distance=1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=2.2.2.1 distance=2 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=3.3.3.1 distance=3 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=4.4.4.1 distance=4 check-gateway=ping

NAT

/ip firewall nat
add chain=srcnat out-interface=WAN1 action=masquerade
add chain=srcnat out-interface=WAN2 action=masquerade
add chain=srcnat out-interface=WAN3 action=masquerade
add chain=srcnat out-interface=WAN4 action=masquerade

dan seperti biasa, semoga rb 750 ini dapat mengerjakan tugasnya dengan baik..

 

Salam,

PentiumSoak

About pentiumsoak

Seseorang biasa dengan impian yang luar biasa, yang berharap mempunyai kehidupan seperti kaleidoskop yang tidak beraturan namun penuh warna. keturunan darah rendah dengan segudang cerita yang tidak patut di tiru, diduga keras mengalami kerusakan parah pada otak kanan yang menimbulkan kemampuan menghapalnya amat sangat minim, sehingga terkadang lupa sudah 1 hari belum makan sama sekali –“

Check Also

xiaomi flasher toolkit

xiaomi flasher toolkit adalah sebuah tools sederhana namun sangat berarti buat saya. kemarin sempet oprek2 …

One comment

Leave a Reply

Your email address will not be published. Required fields are marked *