Sunday, October 22, 2017
Breaking News
Home » Jelambar » torrent blocking dengan mikrotik part 2

torrent blocking dengan mikrotik part 2

huff…

selamat pagi jakarta

meneruskan tulisan saya yang sebelumnya tentang torrent blocking akhirnya munculah part 2. yap part yang akan membahas block torrent dengan mikrotik. pada posting sebelumnya dengan menggunakan metode block allp2p yang sama sekali tidak berpengaruh. akhirnya pengembangan pun berlanjut.

metode kali ini lebih sedikit rumit, namun cukup ampuh untuk dilakukan.

dengan menggunakan regex pada layer 7 protocol

buka terminal dan paste code dibawah ini

[php] /ip firewall layer7-protocol
add comment="pentiumsoak torrent block" name=pentiumsoak-torrentblock regexp=\
"^(\\x13bittorrent protocol|azver\\x01\$|get /scrape\\\?info_hash=get /announce\\\?info_hash=|get /client/bitcomet/|GET /data\\\?fid=)|d1:ad2:id20:|\\x08’7P\\)[RP]" [/php]

lalu pada bagian /ip firewall filter pastekan kode dibawah ini

[php] /ip firewall filter
add action=add-src-to-address-list address-list=Torrent-Conn address-list-timeout=2m chain=forward layer7-protocol=pentiumsoak-torrentblock src-address=125.125.125.0/24 \
src-address-list=!allow-bit
add action=add-src-to-address-list address-list=Torrent-Conn address-list-timeout=2m chain=forward p2p=all-p2p src-address=125.125.125.0/24 src-address-list=!allow-bit
add action=drop chain=forward dst-port=!0-1024,8291,5900,5800,3389,14147,5222,59905 protocol=tcp src-address-list=Torrent-Conn
add action=drop chain=forward dst-port=!0-1024,8291,5900,5800,3389,14147,5222,59905 protocol=udp src-address-list=Torrent-Conn [/php]

isikan src-address dengan kelas ip yang anda gunakan, dan mari beraksi..

demikian cuplikan script ini dengan korban saya sendiri

About pentiumsoak

Seseorang biasa dengan impian yang luar biasa, yang berharap mempunyai kehidupan seperti kaleidoskop yang tidak beraturan namun penuh warna. keturunan darah rendah dengan segudang cerita yang tidak patut di tiru, diduga keras mengalami kerusakan parah pada otak kanan yang menimbulkan kemampuan menghapalnya amat sangat minim, sehingga terkadang lupa sudah 1 hari belum makan sama sekali --"

Check Also

xiaomi flasher toolkit

xiaomi flasher toolkit adalah sebuah tools sederhana namun sangat berarti buat saya. kemarin sempet oprek2 …

Leave a Reply

Your email address will not be published. Required fields are marked *